1. Attachments are working again! Check out this thread for more details and to report any other bugs.

MFD issue

Discussion in 'Gen 2 Prius Audio and Electronics' started by jjaur08, Apr 20, 2024.

  1. jjaur08

    jjaur08 New Member

    Joined:
    Apr 20, 2024
    3
    0
    0
    Location:
    Elk Grove
    Vehicle:
    2006 Prius
    Model:
    Base
    Hello,

    I recently just replaced my 2nd gen Prius MDF, everything is working fine, ac controls are back, audio from the radio, etc. but my battery gauge is missing and I’ve scoured the Internet to see if I could find someone with the same issue, but cannot find a thing.I was wondering if anyone would know why it’s blacked out or missing. The shop I had purchased from does these type of repairs regularly, this is a refurb model with a 1 yr warranty. Theoretically I could take it back and ask them but wanted to know if this is a normal glitch or should I be worried something is wrong with the unit. Please let me know your thoughts.
     

    Attached Files:

  2. ColoradoCrow

    ColoradoCrow Active Member

    Joined:
    Sep 2, 2019
    953
    385
    1
    Location:
    Leawood, KS
    Vehicle:
    2008 Prius
    Model:
    I
    Does it change when you are driving or when the car is in READY mode?
     
  3. jjaur08

    jjaur08 New Member

    Joined:
    Apr 20, 2024
    3
    0
    0
    Location:
    Elk Grove
    Vehicle:
    2006 Prius
    Model:
    Base
    No, it does not. I drove home for about 30 mins and all it shows is the current mpg below. It shows the wheels are moving on the graphic but the battery icon stays blank. I am thinking maybe one of the connectors could not be plug in all the way.
     
  4. dolj

    dolj Senior Member

    Joined:
    May 14, 2012
    7,561
    3,800
    0
    Location:
    Wellington, New Zealand
    Vehicle:
    2007 Prius
    Model:
    N/A
    It's worth checking all the connectors are seated correctly and locked in.
     
  5. jjaur08

    jjaur08 New Member

    Joined:
    Apr 20, 2024
    3
    0
    0
    Location:
    Elk Grove
    Vehicle:
    2006 Prius
    Model:
    Base
    I took it apart today and reconnected everything and am still getting the blanked out battery gauge.
     
  6. dolj

    dolj Senior Member

    Joined:
    May 14, 2012
    7,561
    3,800
    0
    Location:
    Wellington, New Zealand
    Vehicle:
    2007 Prius
    Model:
    N/A
    I'd contact the shop and see what they say. Hopefully, you will get the option of repair or replacement.
     
  7. Aloe

    Aloe Junior Member

    Joined:
    Jan 21, 2024
    47
    4
    0
    Location:
    Canada South
    Vehicle:
    2006 Prius
    Model:
    N/A
    I have a similar problem, on my MFD, I am unable to see the MPG bars page. It will show the current bar on the right side of the screen, but I cannot see the history histogram bars to the left. Everything else works.